$re = '/(^|\s)a(?=\s|$)/m';
$str = 'a a a a';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;