// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\[\s*\[\s*\[\s*([+-]?\d+)\s*,\s*([+-]?\d+)\s*\]\s*,\s*\[\s*([+-]?\d+)\s*,\s*([+-]?\d+)\s*\]\s*,\s*\[\s*([+-]?\d+)\s*,\s*([+-]?\d+)\s*\]\s*\]\s*\]\s*").unwrap();
let string = "[[[5,3],[2,8],[6,-3]]]
[ [ [ 5 , 3 ] , [ 2 , 8 ] , [ 6 , -3 ] ] ]
[[
[ 5, 3],
[ 2, 8],
[ 6,-3]
]]
[
[
[
5,
3
],
[
2,
8
],
[ 6,
-3
]
]
]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}