package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z][.a-z0-9]{2,29}$`)
var str = `f.oo
foo.
f.o.o
fooo
f....
foo.txtasdfasdf
foo
9000
9iiii
9.iiii
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}