$re = '/^[a-z][.a-z0-9]{2,29}$/m';
$str = 'f.oo
foo.
f.o.o
fooo
f....
foo.txtasdfasdf
foo
9000
9iiii
9.iiii
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);