$re = '/^[^ ].*[^ ]$/m';
$str = ' North West
North West
North West
NorthWest
NorthWest
NorthWest
North West
NorthWest
1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);