re = /^[^ ].*[^ ]$/m
str = ' North West
North West
North West
NorthWest
NorthWest
NorthWest
North West
NorthWest
1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end