package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^AI]+|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^D]|$))|(?:I(?:[^J]|$)))+$`)
var str = `ABCD
EFGH
IJKL
MNOP
AABCD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}