re = /^(?:[^AI]+|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^D]|$))|(?:I(?:[^J]|$)))+$/m
str = 'ABCD
EFGH
IJKL
MNOP
AABCD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end