$re = '/([0-9]{1,4}([ /-]?[А-ЯЁ]{1}|))/iu';
$str = '123-';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);