import re
regex = re.compile(r"([0-9]{1,4}([ /-]?[А-ЯЁ]{1}|))", flags=re.IGNORECASE | re.UNICODE)
test_str = "123-"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")