#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\/\/)?(#define) (\w+)(?: ?({[^{}]*})? ?(\/\/ ?(.*))?)?"
Local $sString = "//#define variable_name { 300 }" & @CRLF & _
"" & @CRLF & _
"#define variable_name { 300 }" & @CRLF & _
"" & @CRLF & _
"//#define variable_name" & @CRLF & _
"" & @CRLF & _
"#define variable_name" & @CRLF & _
"" & @CRLF & _
"//#define variable_name { 300 } // Comment" & @CRLF & _
"" & @CRLF & _
"#define variable_name { 300 } // Comment" & @CRLF & _
"" & @CRLF & _
"#define variable_name // Comment" & @CRLF & _
"" & @CRLF & _
"//#define variable_name // Comment"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")