const regex = /^(\/\/)?(#define) (\w+)(?: ?({[^{}]*})? ?(\/\/ ?(.*))?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\/\\\/)?(#define) (\\w+)(?: ?({[^{}]*})? ?(\\\/\\\/ ?(.*))?)?', 'gm')
const str = `//#define variable_name { 300 }
#define variable_name { 300 }
//#define variable_name
#define variable_name
//#define variable_name { 300 } // Comment
#define variable_name { 300 } // Comment
#define variable_name // Comment
//#define variable_name // Comment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}