#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((Jan(uary)?|Mar(ch)?|July?|Aug(ust)?|Oct(ober)?|Dec(ember)?) 31|(Jan(uary)?|Mar(ch)?|Apr(il)?|July?|June?|Aug(ust)?|Oct(ober)?|Sep|(Sept|Nov|Dec)(ember)?) (0?[1-9]|([12]\d)|30)|Feb(ruary)? (0?[1-9]|1\d|2[0-8]|29(?=, ((1[6-9]|[2-9]\d)(0[48]|[2468][048]|[13579][26])|(16|[2468][048]|[3579][26])00)))), (1[6-9]|[2-9]\d)\d{2}"
Local $sString = "Dec 31, 1914" & @CRLF & _
"August 30, 2963" & @CRLF & _
"June 09, 3454" & @CRLF & _
"" & @CRLF & _
"Sept 01, 1900" & @CRLF & _
"Sep 01, 1900" & @CRLF & _
"" & @CRLF & _
"Sep 31, 2016 #Sep 31 doesn't exist" & @CRLF & _
"Feb 29, 2000 #Matches as expected, on x400 year" & @CRLF & _
"February 29, 1900 #Doesn't match, as expected, on x100 (but not 400) year" & @CRLF & _
"February 29, 1904"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")