using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((Jan(uary)?|Mar(ch)?|July?|Aug(ust)?|Oct(ober)?|Dec(ember)?) 31|(Jan(uary)?|Mar(ch)?|Apr(il)?|July?|June?|Aug(ust)?|Oct(ober)?|Sep|(Sept|Nov|Dec)(ember)?) (0?[1-9]|([12]\d)|30)|Feb(ruary)? (0?[1-9]|1\d|2[0-8]|29(?=, ((1[6-9]|[2-9]\d)(0[48]|[2468][048]|[13579][26])|(16|[2468][048]|[3579][26])00)))), (1[6-9]|[2-9]\d)\d{2}";
string input = @"Dec 31, 1914
August 30, 2963
June 09, 3454
Sept 01, 1900
Sep 01, 1900
Sep 31, 2016 #Sep 31 doesn't exist
Feb 29, 2000 #Matches as expected, on x400 year
February 29, 1900 #Doesn't match, as expected, on x100 (but not 400) year
February 29, 1904";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}