using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"RX_IST2_AM\ \[PID:(\d{1,6})\ NPID:(\d{1,5})\ SID:(\d{1,9})\] sbivvrwm060\.dev\.ib\.tor\.Test\.com:30000";
string input = @"RX_IST2_AM [PID:942564 NPID:10991 SID:498702881] sbivvrwm060.dev.ib.tor.Test.com:30000
RX_IST2_AM [PID:1234 NPID:22222 SID:987654321] sbivvrwm060.dev.ib.tor.Test.com:30000
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}