package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`RX_IST2_AM\ \[PID:(\d{1,6})\ NPID:(\d{1,5})\ SID:(\d{1,9})\] sbivvrwm060\.dev\.ib\.tor\.Test\.com:30000`)
var str = `RX_IST2_AM [PID:942564 NPID:10991 SID:498702881] sbivvrwm060.dev.ib.tor.Test.com:30000
RX_IST2_AM [PID:1234 NPID:22222 SID:987654321] sbivvrwm060.dev.ib.tor.Test.com:30000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}