import re
regex = re.compile(r"(\d{2})(\d{3})(\d{3})(\d{4})")
test_str = "111111111111"
subst = "+$1 ($2) $3-$4"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)