import Foundation
let pattern = #"(\d{2})(\d{3})(\d{3})(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"111111111111"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+$1 ($2) $3-$4"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}