package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).replace(/\s(Rs|Rs\.)\s/gi," Rs. ")`)
var str = `RS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}