$re = '/.replace(/\s(Rs|Rs\.)\s/gi," Rs. ")/i';
$str = 'RS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);