package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(((\S?)=(.+),?)+\)`)
var str = `(X=32,Y=3253,Z=12.21)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}