$re = '/\(((\S?)=(.+),?)+\)/';
$str = '(X=32,Y=3253,Z=12.21)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);