# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)(?:,|(?=#LIMIT#))(?=.*#LIMIT#(.*))/\2\1\n/g;t' <<< "red,black,white,pink#LIMIT#122545;bmwx3;new;
red,black,white,pink#LIMIT#ZZZZZZ;bmZZZZ;new;"