$re = '/(\w+)(?:,|(?=#LIMIT#))(?=.*#LIMIT#(.*))/';
$str = 'red,black,white,pink#LIMIT#122545;bmwx3;new;
red,black,white,pink#LIMIT#ZZZZZZ;bmZZZZ;new;';
$subst = "\2\1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;