package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-D](0[1-9]|1\d|2[0-5])`)
var str = `A19
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}