$re = '/[A-D](0[1-9]|1\d|2[0-5])/';
$str = 'A19
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);