import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(>([A-Z ]+?)<|title=\"([\\d-]+))";
final String string = "<a href=\"http://rs.xidian.edu.cn/forum.php?mod=viewthread&tid=662128&extra=page%3D1\" onclick=\"atarget(this)\" class=\"s xst\">GIRL FRIENDS</a>\n"
+ "<span class=\"tps\"> ...<a href=\"http://rs.xidian.edu.cn/forum.php?mod=viewthread&tid=662128&extra=page%3D1&page=2\">2</a></span>\n"
+ "<a href=\"http://rs.xidian.edu.cn/forum.php?mod=redirect&tid=662128&goto=lastpost#lastpost\" class=\"xi1\">New</a>\n"
+ "</th>\n"
+ "<td class=\"by\">\n"
+ "<cite>\n"
+ "<a href=\"http://rs.xidian.edu.cn/home.php?mod=space&uid=265770\" c=\"1\">机器人</a></cite>\n"
+ "<em><span><span title=\"2014-7-31\">昨天 23:55</span></span></em>\n"
+ "</td>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}