# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(>([A-Z ]+?)<|title=\"([\d-]+))"
test_str = ("<a href=\"http://rs.xidian.edu.cn/forum.php?mod=viewthread&tid=662128&extra=page%3D1\" onclick=\"atarget(this)\" class=\"s xst\">GIRL FRIENDS</a>\n"
"<span class=\"tps\"> ...<a href=\"http://rs.xidian.edu.cn/forum.php?mod=viewthread&tid=662128&extra=page%3D1&page=2\">2</a></span>\n"
"<a href=\"http://rs.xidian.edu.cn/forum.php?mod=redirect&tid=662128&goto=lastpost#lastpost\" class=\"xi1\">New</a>\n"
"</th>\n"
"<td class=\"by\">\n"
"<cite>\n"
"<a href=\"http://rs.xidian.edu.cn/home.php?mod=space&uid=265770\" c=\"1\">机器人</a></cite>\n"
"<em><span><span title=\"2014-7-31\">昨天 23:55</span></span></em>\n"
"</td>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.