# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\d{4,5}\w{0,2}(?:\.\w{1,2})?|\w{3}-\d{6})$"
test_str = ("00000\n"
"00000.0\n"
"00000.00\n"
"00000.X\n"
"000000\n"
"000000X\n"
"00000X\n"
"00000X.0\n"
"00000X.0X\n"
"00000X0.0\n"
"00000XX.0\n"
"0000X.0\n"
"XXX-000000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.