$re = '/^(?=.*?[A-Z])(?=.*?[0-9])[0-9A-Z]+$/m';
$str = 'asd7989
7978dfd
auo789dd
9799
a97-99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);