re = /^(?=.*?[A-Z])(?=.*?[0-9])[0-9A-Z]+$/m
str = 'asd7989
7978dfd
auo789dd
9799
a97-99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end