import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^[:alpha:]-]|^)\n"
+ "(\n"
+ " [[:alpha:]]{2,}(?:-[[:alpha:]]{2,})?|\n"
+ " -[[:alpha:]]{2,}|\n"
+ " [[:alpha:]]{2,}-\n"
+ ")\n"
+ "[^[:alpha:]-]\n"
+ "(?:(?:.*?[^[:alpha:]-])?\\1(?:[^[:alpha:]-]|$)){2}";
final String string = "-bad girls, -bad boys,-bad phone. phone phone mam: phone phone? \n"
+ "wup, wup, BORAK OBAMA OBAMA MAMA; it is OBAMA . \n"
+ "hustone, we have a problem, big problem. Very big, big, big\n"
+ "high cost - high perfomance, high \n"
+ "full-hd,tv-full,full-hd:full-hd\n"
+ "1 Fooo fooo fooo , fooo-- fooo-- \n"
+ "2 fooo feee faaa , fooo-fooo, fooo-fooo.";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}