const regex = /(?:[^[:alpha:]-]|^)
(
[[:alpha:]]{2,}(?:-[[:alpha:]]{2,})?|
-[[:alpha:]]{2,}|
[[:alpha:]]{2,}-
)
[^[:alpha:]-]
(?:(?:.*?[^[:alpha:]-])?\1(?:[^[:alpha:]-]|$)){2}/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^[:alpha:]-]|^)
(
[[:alpha:]]{2,}(?:-[[:alpha:]]{2,})?|
-[[:alpha:]]{2,}|
[[:alpha:]]{2,}-
)
[^[:alpha:]-]
(?:(?:.*?[^[:alpha:]-])?\\1(?:[^[:alpha:]-]|$)){2}', 'img')
const str = `-bad girls, -bad boys,-bad phone. phone phone mam: phone phone?
wup, wup, BORAK OBAMA OBAMA MAMA; it is OBAMA .
hustone, we have a problem, big problem. Very big, big, big
high cost - high perfomance, high
full-hd,tv-full,full-hd:full-hd
1 Fooo fooo fooo , fooo-- fooo--
2 fooo feee faaa , fooo-fooo, fooo-fooo.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}