re = /[(\?|\&)]([^=]+)\=([^&#]+)/
str = 'https://www.google.com/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=document.location'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end