import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)[^\\n]*\\blittle\\b(?:(?!\\blittle\\b|\\bfleece\\b).)*fleece[^\\n]*(?:\\n[^\\n]*){4}";
final String string = "1.Mary had a little lamb,\n"
+ "2.Little lamb, little lamb,\n"
+ "3.Mary had a little lamb,\n"
+ "4.Its fleece was white as snow\n"
+ "5.And everywhere that Mary went,\n"
+ "6.Mary went, Mary went,\n"
+ "7.Everywhere that Mary went\n"
+ "8.The lamb was sure to go\n"
+ "9.It followed her to school one day\n"
+ "10.School one day, school one day\n"
+ "11.It followed her to school one day\n"
+ "12.Which was against the rules.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}