# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)[^\n]*\blittle\b(?:(?!\blittle\b|\bfleece\b).)*fleece[^\n]*(?:\n[^\n]*){4}"
test_str = ("1.Mary had a little lamb,\n"
"2.Little lamb, little lamb,\n"
"3.Mary had a little lamb,\n"
"4.Its fleece was white as snow\n"
"5.And everywhere that Mary went,\n"
"6.Mary went, Mary went,\n"
"7.Everywhere that Mary went\n"
"8.The lamb was sure to go\n"
"9.It followed her to school one day\n"
"10.School one day, school one day\n"
"11.It followed her to school one day\n"
"12.Which was against the rules.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.