$re = '/^(.+?)/([\w]+\.log)$/';
$str = '/var/log/xyz/10032008.log';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);