import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\G\\[(?:(?:name:(?<name>[^,\\]]+)|quantity:(?<quantity>[^,\\]]+)|unit_price:(?<unit_price>[^,\\]]+)),?)*\\](?:,|\\z)";
final String string = "[name:pizza,quantity:12,unit_price:3.43],[name:burger,unit_price:40.47,quantity:24],[quantity:4,unit_price:14.47,name:hotdog]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}