use strict;
my $str = '[name:pizza,quantity:12,unit_price:3.43],[name:burger,unit_price:40.47,quantity:24],[quantity:4,unit_price:14.47,name:hotdog]';
my $regex = qr/\G\[(?:(?:name:(?<name>[^,\]]+)|quantity:(?<quantity>[^,\]]+)|unit_price:(?<unit_price>[^,\]]+)),?)*\](?:,|\z)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}