use strict;
my $str = '
Interface IP-Address OK? Method Status Protocol
TenGigabitEthernet1/1 unassigned YES NVRAM up up
Te1/1.200 216.254.132.249 YES NVRAM up up
Te1/1.201 10.201.120.173 YES NVRAM up up
TenGigabitEthernet1/2 10.201.121.46 YES NVRAM up up
TenGigabitEthernet1/3 unassigned YES NVRAM up up
Te1/3.905 198.32.160.89 YES NVRAM up up
Te1/3.908 206.130.10.3 YES NVRAM up up
TenGigabitEthernet1/4 unassigned YES NVRAM administratively down down
TenGigabitEthernet1/5 unassigned YES NVRAM up up
Te1/5.98 216.254.131.1 YES NVRAM up up
Te1/5.100 216.254.130.129 YES NVRAM administratively down down
Te1/5.106 216.254.130.158 YES NVRAM administratively down down
Te1/5.110 216.254.131.149 YES NVRAM up up
Te1/5.111 216.254.131.117 YES NVRAM up up
Te1/5.132 216.254.130.25 YES NVRAM administratively down down
Te1/5.134 216.254.130.29 YES NVRAM up up
Te1/5.205 216.254.141.153 YES NVRAM up up
TenGigabitEthernet1/6 unassigned YES NVRAM up down
TenGigabitEthernet1/7 unassigned YES NVRAM up up
Te1/7.907 198.32.118.14 YES NVRAM up up
TenGigabitEthernet1/8 10.201.121.154 YES NVRAM up up
GigabitEthernet2/1 unassigned YES unset up up
GigabitEthernet2/2 unassigned YES unset administratively down down
GigabitEthernet2/3 unassigned YES unset administratively down down
GigabitEthernet2/4 unassigned YES unset up up
GigabitEthernet2/5 unassigned YES unset administratively down down
';
my $regex = qr/[0-9]*\.[0-9]+\.[0-9]+\.[0-9]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}