import re
regex = re.compile(r"(\"[^\"\\]*(?:\\.[^\"\\]*)*\"|'[^'\\]*(?:\\.[^'\\]*)*')|/\*[^*]*\*+(?:[^/*][^*]*\*+)*/|//[^\r\n]*[\r\n]*")
test_str = ("random text\n"
"/* removable comment */\n"
"\"but /* never remove this */ one\"\n"
"'but /* never remove this */ one either'\n"
"// Text here\n"
"more random *text*\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)