re = /("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/|\/\/[^\r\n]*[\r\n]*/
str = 'random text
/* removable comment */
"but /* never remove this */ one"
\'but /* never remove this */ one either\'
// Text here
more random *text*
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result