$re = '/^(([a-zA-Z]:)|(\\\\{2}\w+)\$?)(\\\\(\w[\w].*))+(.jpeg|.JPEG|.jpg|.JPG)$/m';
$str = 'A:\\12anything.JPEG
\\\\1$\\anything.jpg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);