$re = '/[\n\s\r]+/';
$str = '
test
aeee
eeeee';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;