const regex = /(?<MyGroup> 4\/(.+)(?=(?: \d\/)))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<MyGroup> 4\\\/(.+)(?=(?: \\d\\\/)))', '')
const str = ` 4/abc def 5/abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}