$re = '/(?<MyGroup> 4\/(.+)(?=(?: \d\/)))/';
$str = ' 4/abc def 5/abc';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);