$re = '/(?<=c\()(.*)(?=,\s0\))/m';
$str = 'c(58663.809, 232648.355, 0)
c(5902.873, 232674.248, 0)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);