re = /(?<=c\()(.*)(?=,\s0\))/m
str = 'c(58663.809, 232648.355, 0)
c(5902.873, 232674.248, 0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end