package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(https?:\/\/)?((25[0-5]|2[0-4][\d]|[1][\d][\d]|[1-9][\d]|[\d])(\.|:)?){4}([\d]{2,4})?((\/[\w]+)+)?`)
var str = `http://192.168.0.1
https://192.168.0.1
255.255.255.255
http://192.168.0.1:8080
http://10.3.4.27.
http://10.3.4.27:
http://10.3.4.27:8080
http://10.3.4.27:80
http://1.3.4.27:8080/login
http://10.3.4.27:8080/login/v2/flow/ZWxIGdDQ9WcYHsz7QykGlbiXhbwU0Fpiq4En3nnzeIWyOioS50l9gLgt4CZL0B1IRMGIYhssl1VUMLXsy2uTUKmsAe7VhySHN67BSLROqV4sdK8ilvvR3SSU3tt05PwM) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}