// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(https?:\/\/)?((25[0-5]|2[0-4][\d]|[1][\d][\d]|[1-9][\d]|[\d])(\.|:)?){4}([\d]{2,4})?((\/[\w]+)+)?").unwrap();
let string = "http://192.168.0.1
https://192.168.0.1
255.255.255.255
http://192.168.0.1:8080
http://10.3.4.27.
http://10.3.4.27:
http://10.3.4.27:8080
http://10.3.4.27:80
http://1.3.4.27:8080/login
http://10.3.4.27:8080/login/v2/flow/ZWxIGdDQ9WcYHsz7QykGlbiXhbwU0Fpiq4En3nnzeIWyOioS50l9gLgt4CZL0B1IRMGIYhssl1VUMLXsy2uTUKmsAe7VhySHN67BSLROqV4sdK8ilvvR3SSU3tt05PwM) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}